Community forums English - spreed » Support: technical

DMS file download triggered when starting Spreed app in Nextcloud

(6 posts)

rothjochen
Member

Hello,

i followed the tutorial to setup spreed-webrtc which seemed to work quite well.
I had to compile proxy wstunnel for my Apache 2.2 due to it not being available for this apache version.

The problem is when i open Spree.Me App in NextCloud my Browser starts to download a *.DMS file (no file name given)

I can not see any issues in the logs.

Any ideas whats going wrong here?

Thank you.

Jochen

Posted 1 year ago #

leon
Member

Hi Jochen,

that sounds really strange.
Is this .DMS file empty? Does it come from your Nextcloud Drive?
What's the exact file name? "*.DMS"?

What do you see after opening the Spreed.ME app in Nextclod? A white screen?

Thank you,
Leon

Posted 1 year ago #

rothjochen
Member

Hello Leon,

the DMS file has no name (see the picture attached), when download the file its named "UKBjLuDI.dms" on Firefox, Safari saves the file as "webrtc". The prefix changes on each reload.
The file itself is empty.
The download is triggered when calling this URL: https://cloud.knallimall.org/webrtc/
imho its served by the spreed-webrtc-server.

When i open the Spreed.ME app in Nextcloud i get the nextcloud header, rest of the page stays empty (see the picture attached).

Thanks for your assistance.

Jochen

DMS-file.pngDMS-file.png
Posted 1 year ago #

leon
Member

Hi Jochen,

it looks like you're using Apache. Can you please post your Apache config, i.e. how you set it up as a reverse proxy for Spreed WebRTC?

Please also take a look at our example configuration: https://github.com/strukturag/nextcloud-spreedme/blob/master/doc/example-config-apache.md
Your Apache reports itself as "Apache/2.2.15 (CentOS)", but Apache version 2.4.5 is required to proxy the Websocket protocol. This however is another issue and does not explain why the /webrtc/ endpoint doesn't return anything meaningful.

Cheers,
Leon

Posted 1 year ago #

rothjochen
Member

Hi Leon,

yep, i'm using Apache 2.2 - the mod wstunnel was compiled and included by me. It has a patch which is supposed to make wstunnel work for Apache 2.2 . i Will verify the Apache config on my server according to the link you posted. Next step would be to update Apache to 2.4.

Thanks.

Cheers,
Jochen

Posted 1 year ago #

rothjochen
Member

Hello Leon,

finally i'm running Apache 2.4 :-)

But now i get this:
server 2016/09/29 22:51:02.250144 http: TLS handshake error from 127.0.0.1:52808: tls: first record does not look like a TLS handshake

Seems like something is wrong with my ssl cert.

Posted 1 year ago #

RSS feed for this topic

Reply

You must log in to post.